# CVE-2019-20920: Arbitrary Code Execution in Handlebars


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Sep 2020
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2019-20920, GHSA-3cqr-58rm-57f8, MINI-446m-rr6q-r26p, ROOT-APP-NPM-CVE-2019-20920, SNYK-JS-HANDLEBARS-534478, UBUNTU-CVE-2019-20920

## What is CVE-2019-20920?

CVE-2019-20920 is a high-severity vulnerability in n/a, published on 30 Sep 2020. 

### Official description

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-20920?

4 open source packages ship an affected version, including handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | All versions | 3.0.8 |
| `handlebars` | npm | All versions | 3.0.8 |
| `handlebars` | npm | From 4.0.0 | 4.5.3 |
| `handlebars` | npm | From 4.0.0 | 4.5.3 |

Products: Handlebarsjs Handlebars.

## How do I fix CVE-2019-20920?

Upgrade handlebars to a fixed version for your release line: 3.0.8 or 4.5.3.

## Is CVE-2019-20920 being exploited?

There is no known exploitation of CVE-2019-20920 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-33937](https://insights.sbomify.com/CVE-2026-33937/): Handlebars.js has JavaScript Injection via AST Type Confusion (critical 9.8)
- [CVE-2026-33941](https://insights.sbomify.com/CVE-2026-33941/): Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options (high 8.3)
- [CVE-2026-33938](https://insights.sbomify.com/CVE-2026-33938/): Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block (high 8.1)
- [CVE-2026-33940](https://insights.sbomify.com/CVE-2026-33940/): Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial (high 8.1)
- [CVE-2026-33939](https://insights.sbomify.com/CVE-2026-33939/): Handlebars.js has Denial of Service via Malformed Decorator Syntax in Template Compilation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20920 and fix it if it is affected.

What it is: CVE-2019-20920 is a high-severity vulnerability in n/a, published on 30 Sep 2020. 
Exploitation: There is no known exploitation of CVE-2019-20920 in the wild and no public exploit code.

Affected packages and fixed versions:
- handlebars (npm): affected all versions; fixed in 3.0.8
- handlebars (npm): affected all versions; fixed in 3.0.8
- handlebars (npm): affected from 4.0.0; fixed in 4.5.3
- handlebars (npm): affected from 4.0.0; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20920/ (Markdown: https://insights.sbomify.com/CVE-2019-20920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20920
- OSV: https://osv.dev/vulnerability/CVE-2019-20920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20920/
Summaries are generated and may contain mistakes; the official description above is the record.
