{"answers":{"affected":"6 open source packages ship an affected version, including bootstrap-select. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-20921 in the wild and no public exploit code.","fix":"Upgrade bootstrap-select to 1.13.6 or later.","what":"CVE-2019-20921 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-20921 and fix it if it is affected.\n\nWhat it is: CVE-2019-20921 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-20921 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bootstrap-select (NuGet): affected all versions; fixed in 1.13.6\n- bootstrap-select (NuGet): affected all versions; fixed in 1.13.6\n- bootstrap-select (npm): affected all versions; fixed in 1.13.6\n- bootstrap-select (npm): affected all versions; fixed in 1.13.6\n- bootstrap-select (npm): affected all versions; fixed in 1.13.6\n- bootstrap-select (npm): affected all versions; fixed in 1.13.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-20921/ (Markdown: https://insights.sbomify.com/CVE-2019-20921/index.md)","id":"CVE-2019-20921","markdown":"https://insights.sbomify.com/CVE-2019-20921/index.md","name":"CVE-2019-20921","record":{"aliases":["GHSA-7c82-mp33-r854","GHSA-9r7h-6639-v5mw","SNYK-JS-BOOTSTRAPSELECT-570457"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unescaped title values in bootstrap-select OPTION elements.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bootstrap-select","vendor":"snapappointments"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.","ecosystems":["NuGet","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in bootstrap-select","id":"CVE-2019-20921","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":6,"n_references":5,"next":{"headline":"Regular Expression Denial of Service in Handlebars","id":"CVE-2019-20922"},"packages":[{"ecosystem":"NuGet","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":null,"source":"GHSA-7c82-mp33-r854"},{"ecosystem":"NuGet","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":"pkg:nuget/bootstrap-select","source":"GHSA-7c82-mp33-r854"},{"ecosystem":"npm","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":null,"source":"GHSA-7c82-mp33-r854"},{"ecosystem":"npm","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":"pkg:npm/bootstrap-select","source":"GHSA-7c82-mp33-r854"},{"ecosystem":"npm","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":null,"source":"GHSA-9r7h-6639-v5mw"},{"ecosystem":"npm","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"bootstrap-select","purl":"pkg:npm/bootstrap-select","source":"GHSA-9r7h-6639-v5mw"}],"prev":{"headline":"Arbitrary Code Execution in Handlebars","id":"CVE-2019-20920"},"products":["n/a"],"published":"2020-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-11-25","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unescaped title values in bootstrap-select OPTION elements.","url":"https://insights.sbomify.com/CVE-2019-20921/"}