# CVE-2019-20921: Cross-site scripting in bootstrap-select

> Attackers can execute arbitrary JavaScript in victims' browsers via unescaped title values in bootstrap-select OPTION elements.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2020
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-7c82-mp33-r854, GHSA-9r7h-6639-v5mw, SNYK-JS-BOOTSTRAPSELECT-570457

## What is CVE-2019-20921?

CVE-2019-20921 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-20921?

6 open source packages ship an affected version, including bootstrap-select. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap-select` | NuGet | All versions | 1.13.6 |
| `bootstrap-select` | NuGet | All versions | 1.13.6 |
| `bootstrap-select` | npm | All versions | 1.13.6 |
| `bootstrap-select` | npm | All versions | 1.13.6 |
| `bootstrap-select` | npm | All versions | 1.13.6 |
| `bootstrap-select` | npm | All versions | 1.13.6 |

Products: Snapappointments Bootstrap-Select.

## How do I fix CVE-2019-20921?

Upgrade bootstrap-select to 1.13.6 or later.

## Is CVE-2019-20921 being exploited?

There is no known exploitation of CVE-2019-20921 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20921 and fix it if it is affected.

What it is: CVE-2019-20921 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-20921 in the wild and no public exploit code.

Affected packages and fixed versions:
- bootstrap-select (NuGet): affected all versions; fixed in 1.13.6
- bootstrap-select (NuGet): affected all versions; fixed in 1.13.6
- bootstrap-select (npm): affected all versions; fixed in 1.13.6
- bootstrap-select (npm): affected all versions; fixed in 1.13.6
- bootstrap-select (npm): affected all versions; fixed in 1.13.6
- bootstrap-select (npm): affected all versions; fixed in 1.13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20921/ (Markdown: https://insights.sbomify.com/CVE-2019-20921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20921
- OSV: https://osv.dev/vulnerability/CVE-2019-20921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20921/
Summaries are generated and may contain mistakes; the official description above is the record.
