# CVE-2019-20922: Regular Expression Denial of Service in Handlebars

> Attackers can cause resource exhaustion and service disruption in applications using Handlebars by submitting crafted templates that trigger excessive regex processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-62gr-4qp9-h98f, SNYK-JS-HANDLEBARS-480388, UBUNTU-CVE-2019-20922

## What is CVE-2019-20922?

CVE-2019-20922 is a high-severity denial of service vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Handlebars before 4.4.5 allows Regular Expression Denial of Service (ReDoS) because of eager matching. The parser may be forced into an endless loop while processing crafted templates. This may allow attackers to exhaust system resources.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-20922?

2 open source packages ship an affected version, including handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | From 4.0.0 | 4.4.5 |
| `handlebars` | npm | From 4.0.0 | 4.4.5 |

Products: Handlebarsjs Handlebars.

## How do I fix CVE-2019-20922?

Upgrade handlebars to 4.4.5 or later.

## Is CVE-2019-20922 being exploited?

There is no known exploitation of CVE-2019-20922 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-33937](https://insights.sbomify.com/CVE-2026-33937/): Handlebars.js has JavaScript Injection via AST Type Confusion (critical 9.8)
- [CVE-2026-33941](https://insights.sbomify.com/CVE-2026-33941/): Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options (high 8.3)
- [CVE-2026-33938](https://insights.sbomify.com/CVE-2026-33938/): Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block (high 8.1)
- [CVE-2026-33940](https://insights.sbomify.com/CVE-2026-33940/): Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial (high 8.1)
- [CVE-2019-20920](https://insights.sbomify.com/CVE-2019-20920/): Arbitrary Code Execution in Handlebars (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20922 and fix it if it is affected.

What it is: CVE-2019-20922 is a high-severity denial of service vulnerability in n/a, published on 30 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20922 in the wild and no public exploit code.

Affected packages and fixed versions:
- handlebars (npm): affected from 4.0.0; fixed in 4.4.5
- handlebars (npm): affected from 4.0.0; fixed in 4.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20922/ (Markdown: https://insights.sbomify.com/CVE-2019-20922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20922
- OSV: https://osv.dev/vulnerability/CVE-2019-20922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20922/
Summaries are generated and may contain mistakes; the official description above is the record.
