# CVE-2019-20933: Improper Authentication in InfluxDB

> Attackers can bypass authentication in InfluxDB by using a JWT token with an empty shared secret, gaining unauthorized access.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-20933, DLA-2501-1, DSA-4823-1, GHSA-2rmp-fw5r-j5qv, GO-2022-0780, UBUNTU-CVE-2019-20933, USN-5451-1

## What is CVE-2019-20933?

CVE-2019-20933 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate function in services/httpd/handler.go because a JWT token may have an empty SharedSecret (aka shared secret).

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-20933?

3 open source packages ship an affected version, including github.com/influxdata/influxdb. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/influxdata/influxdb` | Go | All versions | 1.7.6 |
| `github.com/influxdata/influxdb` | Go | All versions | 1.7.6 |
| `github.com/influxdata/influxdb` | Go | All versions | 1.7.6 |

Products: Debian Debian Linux, Influxdata Influxdb.

## How do I fix CVE-2019-20933?

Upgrade github.com/influxdata/influxdb to 1.7.6 or later.

## Is CVE-2019-20933 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-20933 exists.

Public exploit code:

- InfluxDB CVE-2019-20933 vulnerability exploit (github_poc): https://github.com/LorenzoTullini/InfluxDB-Exploit-CVE-2019-20933
- https://github.com/Hydragyrum/CVE-2019-20933 (github_poc): https://github.com/Hydragyrum/CVE-2019-20933
- Lab 5: InfluxDB Authentication Bypass (CVE-2019-20933) - Writeup and Exploit (github_poc): https://github.com/Dungsocool/CVE-2019-20933
- Vulhub influxdb/CVE-2019-20933: InfluxDB Empty JWT Secret Authentication Bypass (CVE-2019-20933), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-influxdb-cve-2019-20933
- InfluxDB <1.7.6 - Authentication Bypass (nuclei): http/cves/2019/CVE-2019-20933.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20933 and fix it if it is affected.

What it is: CVE-2019-20933 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-20933 exists.

Affected packages and fixed versions:
- github.com/influxdata/influxdb (Go): affected all versions; fixed in 1.7.6
- github.com/influxdata/influxdb (Go): affected all versions; fixed in 1.7.6
- github.com/influxdata/influxdb (Go): affected all versions; fixed in 1.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20933/ (Markdown: https://insights.sbomify.com/CVE-2019-20933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20933
- OSV: https://osv.dev/vulnerability/CVE-2019-20933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20933/
Summaries are generated and may contain mistakes; the official description above is the record.
