# CVE-2019-2391: JS-bson may incorrectly serialise some requests

> Incorrect JSON parsing in the js-bson library may lead to improper serialization and potential data disclosure.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-2391, GHSA-4jwp-vfvf-657p, ROOT-APP-NPM-CVE-2019-2391, UBUNTU-CVE-2019-2391

## What is CVE-2019-2391?

CVE-2019-2391 is a medium-severity unsafe deserialization vulnerability in MongoDB Inc. js-bson, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect parsing of certain JSON input may result in js-bson not correctly serializing BSON. This may cause unexpected application behaviour including data disclosure. This issue affects: MongoDB Inc. js-bson library version 1.1.3 and prior to.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-2391?

2 open source packages ship an affected version, including bson. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bson` | npm | All versions | 1.1.4 |
| `bson` | npm | All versions | 1.1.4 |

Products: Mongodb Js-Bson.

## How do I fix CVE-2019-2391?

Upgrade bson to 1.1.4 or later.

## Is CVE-2019-2391 being exploited?

There is no known exploitation of CVE-2019-2391 in the wild and no public exploit code.

## Other vulnerabilities in MongoDB Inc. js-bson

- [CVE-2018-13863](https://insights.sbomify.com/CVE-2018-13863/): js-bson vulnerable to REDoS (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-2391 and fix it if it is affected.

What it is: CVE-2019-2391 is a medium-severity unsafe deserialization vulnerability in MongoDB Inc. js-bson, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-2391 in the wild and no public exploit code.

Affected packages and fixed versions:
- bson (npm): affected all versions; fixed in 1.1.4
- bson (npm): affected all versions; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-2391/ (Markdown: https://insights.sbomify.com/CVE-2019-2391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-2391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-2391
- OSV: https://osv.dev/vulnerability/CVE-2019-2391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-2391/
Summaries are generated and may contain mistakes; the official description above is the record.
