# CVE-2019-2435: Improper Access Control in MySQL Connector Python

> An unauthenticated attacker can compromise MySQL Connector/Python via TLS to read, modify, or delete accessible data, requiring user interaction.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2019
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-v5rq-w2xm-7g5f, MGASA-2020-0345, PYSEC-2026-683, UBUNTU-CVE-2019-2435, openSUSE-SU-2020:0409-1, openSUSE-SU-2020:0430-1

## What is CVE-2019-2435?

CVE-2019-2435 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 16 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data. CVSS 3.0 Base Score 8.1 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N).

## Which versions are affected by CVE-2019-2435?

5 open source packages ship an affected version, including mysql-connector-python. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql-connector-python` | PyPI | From 2.1.0 to 2.1.8 | None |
| `mysql-connector-python` | PyPI | From 2.1.0 to 2.1.8 | None |
| `mysql-connector-python` | PyPI | From 2.1.0 | 8.0.19 |
| `mysql-connector-python` | PyPI | From 8.0.0 | 8.0.19 |
| `mysql-connector-python` | PyPI | From 8.0.0 | 8.0.19 |
| `python-mysql-connector-python` | SUSE:Package Hub 15 SP1 | All versions | 8.0.19-bp151.4.3.1 |
| `python-mysql-connector-python` | openSUSE:Leap 15.1 | All versions | 8.0.19-lp151.3.3.1 |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql Connectors.

## How do I fix CVE-2019-2435?

Upgrade mysql-connector-python to 8.0.19 or later.

## Is CVE-2019-2435 being exploited?

There is no known exploitation of CVE-2019-2435 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-2435 and fix it if it is affected.

What it is: CVE-2019-2435 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 16 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-2435 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql-connector-python (PyPI): affected from 2.1.0 up to 2.1.8; no fix listed
- mysql-connector-python (PyPI): affected from 2.1.0 up to 2.1.8; no fix listed
- mysql-connector-python (PyPI): affected from 2.1.0; fixed in 8.0.19
- mysql-connector-python (PyPI): affected from 8.0.0; fixed in 8.0.19
- mysql-connector-python (PyPI): affected from 8.0.0; fixed in 8.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-2435/ (Markdown: https://insights.sbomify.com/CVE-2019-2435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-2435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-2435
- OSV: https://osv.dev/vulnerability/CVE-2019-2435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-2435/
Summaries are generated and may contain mistakes; the official description above is the record.
