# CVE-2019-25007: Incorrect implementation in streebog

> A panic in the Streebog hash function allows attackers to cause a denial of service in applications using the Rust crate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-39wr-f4ff-xm6p

## What is CVE-2019-25007?

CVE-2019-25007 is a high-severity denial of service vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the streebog crate before 0.8.0 for Rust. The Streebog hash function can cause a panic.

## Which versions are affected by CVE-2019-25007?

2 open source packages ship an affected version, including streebog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `streebog` | crates.io | All versions | 0.8.0 |
| `streebog` | crates.io | All versions | 0.8.0 |

Products: Streebog Project Streebog.

## How do I fix CVE-2019-25007?

Upgrade streebog to 0.8.0 or later.

## Is CVE-2019-25007 being exploited?

There is no known exploitation of CVE-2019-25007 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-25006](https://insights.sbomify.com/CVE-2019-25006/): Incorrect implementation of the Streebog hash functions in streebog (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25007 and fix it if it is affected.

What it is: CVE-2019-25007 is a high-severity denial of service vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25007 in the wild and no public exploit code.

Affected packages and fixed versions:
- streebog (crates.io): affected all versions; fixed in 0.8.0
- streebog (crates.io): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25007/ (Markdown: https://insights.sbomify.com/CVE-2019-25007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25007
- OSV: https://osv.dev/vulnerability/CVE-2019-25007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25007/
Summaries are generated and may contain mistakes; the official description above is the record.
