# CVE-2019-25009: Double free in http

> A soundness issue in the Rust http crate's HeaderMap::Drain API allows memory corruption, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-25009, GHSA-6rhx-hqxm-8p36, RUSTSEC-2019-0034, UBUNTU-CVE-2019-25009

## What is CVE-2019-25009?

CVE-2019-25009 is a critical memory corruption vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the http crate before 0.1.20 for Rust. The HeaderMap::Drain API can use a raw pointer, defeating soundness.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2019-25009?

3 open source packages ship an affected version, including http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `http` | crates.io | All versions | 0.1.20 |
| `http` | crates.io | All versions | 0.1.20 |
| `http` | crates.io | From 0.0.0-0 | 0.1.20 |

Products: Hyper Http.

## How do I fix CVE-2019-25009?

Upgrade http to 0.1.20 or later.

## Is CVE-2019-25009 being exploited?

There is no known exploitation of CVE-2019-25009 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-25574](https://insights.sbomify.com/CVE-2020-25574/): Integer Overflow/Infinite Loop in the http crate (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25009 and fix it if it is affected.

What it is: CVE-2019-25009 is a critical memory corruption vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25009 in the wild and no public exploit code.

Affected packages and fixed versions:
- http (crates.io): affected all versions; fixed in 0.1.20
- http (crates.io): affected all versions; fixed in 0.1.20
- http (crates.io): affected from 0.0.0-0; fixed in 0.1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25009/ (Markdown: https://insights.sbomify.com/CVE-2019-25009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25009
- OSV: https://osv.dev/vulnerability/CVE-2019-25009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25009/
Summaries are generated and may contain mistakes; the official description above is the record.
