{"answers":{"affected":"2 open source packages ship an affected version, including activerecord-session_store. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25025 in the wild and no public exploit code.","fix":"Upgrade activerecord-session_store to 2.0.0 or later.","what":"CVE-2019-25025 is a medium-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-25025 and fix it if it is affected.\n\nWhat it is: CVE-2019-25025 is a medium-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-25025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord-session_store (RubyGems): affected all versions; fixed in 2.0.0\n- activerecord-session_store (RubyGems): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25025/ (Markdown: https://insights.sbomify.com/CVE-2019-25025/index.md)","id":"CVE-2019-25025","markdown":"https://insights.sbomify.com/CVE-2019-25025/index.md","name":"CVE-2019-25025","record":{"aliases":["GHSA-cvw2-xj8r-mjf7","UBUNTU-CVE-2019-25025"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails session store","requires_auth":"none","summary":"Remote attackers can guess valid session IDs via timing side-channels, potentially leading to account takeover in Ruby on Rails applications.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"active_record_session_store","vendor":"rubyonrails"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[],"description":"The activerecord-session_store (aka Active Record Session Store) component through 1.1.3 for Ruby on Rails does not use a constant-time approach when delivering information about whether a guessed session ID is valid. Consequently, remote attackers can leverage timing discrepancies to achieve a correct guess in a relatively short amount of time. This is a related issue to CVE-2019-16782.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Activerecord-session_store Vulnerable to Timing Attack","id":"CVE-2019-25025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-25026"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"activerecord-session_store","purl":null,"source":"GHSA-cvw2-xj8r-mjf7"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"activerecord-session_store","purl":"pkg:gem/activerecord-session_store","source":"GHSA-cvw2-xj8r-mjf7"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-25024"},"products":["n/a"],"published":"2021-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can guess valid session IDs via timing side-channels, potentially leading to account takeover in Ruby on Rails applications.","url":"https://insights.sbomify.com/CVE-2019-25025/"}