# CVE-2019-25025: Activerecord-session_store Vulnerable to Timing Attack

> Remote attackers can guess valid session IDs via timing side-channels, potentially leading to account takeover in Ruby on Rails applications.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cvw2-xj8r-mjf7, UBUNTU-CVE-2019-25025

## What is CVE-2019-25025?

CVE-2019-25025 is a medium-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The activerecord-session_store (aka Active Record Session Store) component through 1.1.3 for Ruby on Rails does not use a constant-time approach when delivering information about whether a guessed session ID is valid. Consequently, remote attackers can leverage timing discrepancies to achieve a correct guess in a relatively short amount of time. This is a related issue to CVE-2019-16782.

## Which versions are affected by CVE-2019-25025?

2 open source packages ship an affected version, including activerecord-session_store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord-session_store` | RubyGems | All versions | 2.0.0 |
| `activerecord-session_store` | RubyGems | All versions | 2.0.0 |

Products: Rubyonrails Active Record Session Store.

## How do I fix CVE-2019-25025?

Upgrade activerecord-session_store to 2.0.0 or later.

## Is CVE-2019-25025 being exploited?

There is no known exploitation of CVE-2019-25025 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25025 and fix it if it is affected.

What it is: CVE-2019-25025 is a medium-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25025 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord-session_store (RubyGems): affected all versions; fixed in 2.0.0
- activerecord-session_store (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25025/ (Markdown: https://insights.sbomify.com/CVE-2019-25025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25025
- OSV: https://osv.dev/vulnerability/CVE-2019-25025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25025/
Summaries are generated and may contain mistakes; the official description above is the record.
