# CVE-2019-25027: Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13

> Attackers can execute malicious JavaScript via crafted URLs due to missing output sanitization in the default RouteNotFoundError view of Vaadin flow-server.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rp4x-wxqv-cf9m

## What is CVE-2019-25027?

CVE-2019-25027 is a medium-severity cross-site scripting vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Missing output sanitization in default RouteNotFoundError view in com.vaadin:flow-server versions 1.0.0 through 1.0.10 (Vaadin 10.0.0 through 10.0.13), and 1.1.0 through 1.4.2 (Vaadin 11.0.0 through 13.0.5) allows attacker to execute malicious JavaScript via crafted URL

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-81 (Improper Neutralization of Script in an Error Message Web Page)

## Which versions are affected by CVE-2019-25027?

4 open source packages ship an affected version, including com.vaadin:flow-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:flow-server` | Maven | From 1.0.0 | 1.0.11 |
| `com.vaadin:flow-server` | Maven | From 1.0.0 | 1.0.11 |
| `com.vaadin:flow-server` | Maven | From 1.1.0 | 1.4.3 |
| `com.vaadin:flow-server` | Maven | From 1.1.0 | 1.4.3 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2019-25027?

Upgrade com.vaadin:flow-server to a fixed version for your release line: 1.0.11 or 1.4.3.

## Is CVE-2019-25027 being exploited?

There is no known exploitation of CVE-2019-25027 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31407](https://insights.sbomify.com/CVE-2021-31407/): Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 (high 8.6)
- [CVE-2021-31405](https://insights.sbomify.com/CVE-2021-31405/): Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 (high 7.5)
- [CVE-2021-31411](https://insights.sbomify.com/CVE-2021-31411/): Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19 (medium 6.3)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2020-36321](https://insights.sbomify.com/CVE-2020-36321/): Directory traversal in development mode handler in Vaadin 14 and 15-17 (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25027 and fix it if it is affected.

What it is: CVE-2019-25027 is a medium-severity cross-site scripting vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-25027 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:flow-server (Maven): affected from 1.0.0; fixed in 1.0.11
- com.vaadin:flow-server (Maven): affected from 1.0.0; fixed in 1.0.11
- com.vaadin:flow-server (Maven): affected from 1.1.0; fixed in 1.4.3
- com.vaadin:flow-server (Maven): affected from 1.1.0; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25027/ (Markdown: https://insights.sbomify.com/CVE-2019-25027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25027
- OSV: https://osv.dev/vulnerability/CVE-2019-25027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25027/
Summaries are generated and may contain mistakes; the official description above is the record.
