# CVE-2019-25050: Memory corruption in n/a

> A stack-based buffer overflow in GDAL's netCDF handling allows attackers to execute arbitrary code or cause denial of service via crafted files.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2021
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-25050, GHSA-723m-9g33-2g82, JLSEC-2026-282, PYSEC-2021-888, UBUNTU-CVE-2019-25050

## What is CVE-2019-25050?

CVE-2019-25050 is a high-severity memory corruption vulnerability in n/a, published on 20 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

netCDF in GDAL 2.4.2 through 3.0.4 has a stack-based buffer overflow in nc4_get_att (called from nc4_get_att_tc and nc_get_att_text) and in uffd_cleanup (called from netCDFDataset::~netCDFDataset and netCDFDataset::~netCDFDataset).

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2019-25050?

1 open source package ship an affected version, including gdal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | PyPI | From 2.4.2 | 3.1.0 |

Products: Osgeo Gdal.

## How do I fix CVE-2019-25050?

Upgrade gdal to 3.1.0 or later.

## Is CVE-2019-25050 being exploited?

There is no known exploitation of CVE-2019-25050 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-49014](https://insights.sbomify.com/CVE-2026-49014/): GDAL: scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow (high 7.4)
- [CVE-2025-29480](https://insights.sbomify.com/CVE-2025-29480/): Memory corruption in n/a (medium 5.5)
- [CVE-2026-8212](https://insights.sbomify.com/CVE-2026-8212/): OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8213](https://insights.sbomify.com/CVE-2026-8213/): OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8084](https://insights.sbomify.com/CVE-2026-8084/): OSGeo gdal HDF-EOS Grid File SWapi.c memmove out-of-bounds (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25050 and fix it if it is affected.

What it is: CVE-2019-25050 is a high-severity memory corruption vulnerability in n/a, published on 20 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25050 in the wild and no public exploit code.

Affected packages and fixed versions:
- gdal (PyPI): affected from 2.4.2; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25050/ (Markdown: https://insights.sbomify.com/CVE-2019-25050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25050
- OSV: https://osv.dev/vulnerability/CVE-2019-25050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25050/
Summaries are generated and may contain mistakes; the official description above is the record.
