{"answers":{"affected":"5 open source packages ship an affected version, including libpulse-binding. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25055 in the wild and no public exploit code.","fix":"Upgrade libpulse-binding to 2.6.0 or later.","what":"CVE-2019-25055 is a high-severity vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-25055 and fix it if it is affected.\n\nWhat it is: CVE-2019-25055 is a high-severity vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-25055 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libpulse-binding (crates.io): affected all versions; fixed in 2.6.0\n- libpulse-binding (crates.io): affected all versions; fixed in 2.6.0\n- libpulse-binding (crates.io): affected all versions; fixed in 2.6.0\n- libpulse-binding (crates.io): affected all versions; fixed in 2.6.0\n- libpulse-binding (crates.io): affected from 0.0.0-0; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25055/ (Markdown: https://insights.sbomify.com/CVE-2019-25055/index.md)","id":"CVE-2019-25055","markdown":"https://insights.sbomify.com/CVE-2019-25055/index.md","name":"CVE-2019-25055","record":{"aliases":["GHSA-wcxc-jf6c-8rx9","GHSA-xvcg-2q82-r87j","RUSTSEC-2019-0038"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust PulseAudio binding","requires_auth":"none","summary":"A panic crossing the FFI boundary in the libpulse-binding crate can cause a denial of service in Rust applications using PulseAudio.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libpulse-binding","vendor":"libpulse-binding_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Duplicate Advisory: Uncaught Exception in libpulse-binding","id":"CVE-2019-25055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2019"},"n_packages":5,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2019-25056"},"packages":[{"ecosystem":"crates.io","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"libpulse-binding","purl":null,"source":"GHSA-wcxc-jf6c-8rx9"},{"ecosystem":"crates.io","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"libpulse-binding","purl":"pkg:cargo/libpulse-binding","source":"GHSA-wcxc-jf6c-8rx9"},{"ecosystem":"crates.io","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"libpulse-binding","purl":null,"source":"GHSA-xvcg-2q82-r87j"},{"ecosystem":"crates.io","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"libpulse-binding","purl":"pkg:cargo/libpulse-binding","source":"GHSA-xvcg-2q82-r87j"},{"ecosystem":"crates.io","fixed":["2.6.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libpulse-binding","purl":"pkg:cargo/libpulse-binding","source":"RUSTSEC-2019-0038"}],"prev":{"headline":"Missing Initialization of Resource in pnet","id":"CVE-2019-25054"},"products":["n/a"],"published":"2021-12-26","related":[{"cvss_score":7.5,"headline":"Use after free in n/a","id":"CVE-2018-25027","kev_date_added":null,"published":"2021-12-26"},{"cvss_score":7.5,"headline":"Use after free in n/a","id":"CVE-2018-25028","kev_date_added":null,"published":"2021-12-26"},{"cvss_score":6.5,"headline":"Duplicate Advisory: Use after free in libpulse-binding","id":"CVE-2018-25001","kev_date_added":null,"published":"2020-12-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A panic crossing the FFI boundary in the libpulse-binding crate can cause a denial of service in Rust applications using PulseAudio.","url":"https://insights.sbomify.com/CVE-2019-25055/"}