# CVE-2019-25060: WP-GraphQL < 0.3.5 - Improper Access Control

> Remote attackers can retrieve user role information via GraphQL queries, exposing sensitive account details in WPGraphQL.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w3xg-7q6m-3xwp

## What is CVE-2019-25060?

CVE-2019-25060 is a medium-severity vulnerability in Unknown WPGraphQL, published on 9 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-25060?

2 open source packages ship an affected version, including wp-graphql/wp-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-graphql/wp-graphql` | Packagist | All versions | 0.3.5 |
| `wp-graphql/wp-graphql` | Packagist | All versions | 0.3.5 |

Products: Wpgraphql Wpgraphql.

## How do I fix CVE-2019-25060?

Upgrade wp-graphql/wp-graphql to 0.3.5 or later.

## Is CVE-2019-25060 being exploited?

There is no known exploitation of CVE-2019-25060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25060 and fix it if it is affected.

What it is: CVE-2019-25060 is a medium-severity vulnerability in Unknown WPGraphQL, published on 9 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25060 in the wild and no public exploit code.

Affected packages and fixed versions:
- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 0.3.5
- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 0.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25060/ (Markdown: https://insights.sbomify.com/CVE-2019-25060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25060
- OSV: https://osv.dev/vulnerability/CVE-2019-25060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25060/
Summaries are generated and may contain mistakes; the official description above is the record.
