# CVE-2019-25075: Path Traversal in Gravitee API Management

> Anonymous attackers can read arbitrary files via path traversal in the Gravitee API Management registration endpoint.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xc4w-28g8-vqm5

## What is CVE-2019-25075?

CVE-2019-25075 is a medium-severity path traversal vulnerability in n/a, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HTML injection combined with path traversal in the Email service in Gravitee API Management before 1.25.3 allows anonymous users to read arbitrary files via a /management/users/register request.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-25075?

2 open source packages ship an affected version, including io.gravitee.apim:gravitee-api-management. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.gravitee.apim:gravitee-api-management` | Maven | All versions | 1.25.3 |
| `io.gravitee.apim:gravitee-api-management` | Maven | All versions | 1.25.3 |

Products: Gravitee Api Management.

## How do I fix CVE-2019-25075?

Upgrade io.gravitee.apim:gravitee-api-management to 1.25.3 or later.

## Is CVE-2019-25075 being exploited?

There is no known exploitation of CVE-2019-25075 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-38723](https://insights.sbomify.com/CVE-2022-38723/): Gravitee API Management contains Path Traversal (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25075 and fix it if it is affected.

What it is: CVE-2019-25075 is a medium-severity path traversal vulnerability in n/a, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-25075 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.gravitee.apim:gravitee-api-management (Maven): affected all versions; fixed in 1.25.3
- io.gravitee.apim:gravitee-api-management (Maven): affected all versions; fixed in 1.25.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25075/ (Markdown: https://insights.sbomify.com/CVE-2019-25075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25075
- OSV: https://osv.dev/vulnerability/CVE-2019-25075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25075/
Summaries are generated and may contain mistakes; the official description above is the record.
