CVE-2019-25078 pacparser pacparser.c pacparser_find_proxy buffer overflow

Medium 5.3 Published Updated

A local buffer overflow in pacparser allows attackers to potentially execute code or cause denial of service via a crafted URL.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2019-25078?

CVE-2019-25078 is a medium-severity memory corruption vulnerability in unspecified pacparser, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.

Weakness: CWE-120, CWE-119

Which versions are affected by CVE-2019-25078?

1 open source package ship an affected version, including pacparser. It affects 1 product.

PackageAffectedFixed in
pacparser PyPIAll versions1.4.0

Products include Pacparser Project Pacparser.

How do I fix CVE-2019-25078?

Upgrade pacparser to 1.4.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2019-25078 being exploited?

There is no known exploitation of CVE-2019-25078 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-25078, GHSA-qw3q-5v45-72r8, PYSEC-2022-43062, UBUNTU-CVE-2019-25078.

Is CVE-2019-25078 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free