{"answers":{"affected":"1 open source package ship an affected version, including pacparser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25078 in the wild and no public exploit code.","fix":"Upgrade pacparser to 1.4.0 or later.","what":"CVE-2019-25078 is a medium-severity memory corruption vulnerability in unspecified pacparser, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-25078 and fix it if it is affected.\n\nWhat it is: CVE-2019-25078 is a medium-severity memory corruption vulnerability in unspecified pacparser, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-25078 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pacparser (PyPI): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25078/ (Markdown: https://insights.sbomify.com/CVE-2019-25078/index.md)","id":"CVE-2019-25078","markdown":"https://insights.sbomify.com/CVE-2019-25078/index.md","name":"CVE-2019-25078","record":{"aliases":["DEBIAN-CVE-2019-25078","GHSA-qw3q-5v45-72r8","PYSEC-2022-43062","UBUNTU-CVE-2019-25078"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PAC parsing library","requires_auth":"low_privilege","summary":"A local buffer overflow in pacparser allows attackers to potentially execute code or cause denial of service via a crafted URL.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pacparser","vendor":"pacparser_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pacparser pacparser.c pacparser_find_proxy buffer overflow","id":"CVE-2019-25078","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2019"},"n_packages":1,"n_references":4,"next":{"headline":"This candidate is unused by its CNA.","id":"CVE-2019-25079"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"pacparser","purl":"pkg:pypi/pacparser","source":"PYSEC-2022-43062"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2019-25076"},"products":["pacparser"],"published":"2022-12-13","related":[{"cvss_score":5.9,"headline":"Code injection in n/a","id":"CVE-2023-37360","kev_date_added":null,"published":"2023-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["unspecified"]},"summary":"A local buffer overflow in pacparser allows attackers to potentially execute code or cause denial of service via a crafted URL.","url":"https://insights.sbomify.com/CVE-2019-25078/"}