# CVE-2019-25078: pacparser pacparser.c pacparser_find_proxy buffer overflow

> A local buffer overflow in pacparser allows attackers to potentially execute code or cause denial of service via a crafted URL.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-25078, GHSA-qw3q-5v45-72r8, PYSEC-2022-43062, UBUNTU-CVE-2019-25078

## What is CVE-2019-25078?

CVE-2019-25078 is a medium-severity memory corruption vulnerability in unspecified pacparser, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2019-25078?

1 open source package ship an affected version, including pacparser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pacparser` | PyPI | All versions | 1.4.0 |

Products: Pacparser Project Pacparser.

## How do I fix CVE-2019-25078?

Upgrade pacparser to 1.4.0 or later.

## Is CVE-2019-25078 being exploited?

There is no known exploitation of CVE-2019-25078 in the wild and no public exploit code.

## Other vulnerabilities in unspecified pacparser

- [CVE-2023-37360](https://insights.sbomify.com/CVE-2023-37360/): Code injection in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25078 and fix it if it is affected.

What it is: CVE-2019-25078 is a medium-severity memory corruption vulnerability in unspecified pacparser, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25078 in the wild and no public exploit code.

Affected packages and fixed versions:
- pacparser (PyPI): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25078/ (Markdown: https://insights.sbomify.com/CVE-2019-25078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25078
- OSV: https://osv.dev/vulnerability/CVE-2019-25078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25078/
Summaries are generated and may contain mistakes; the official description above is the record.
