CVE-2019-25090 FreePBX arimanager Views cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts via the dataurl argument in FreePBX arimanager Views, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2019-25090?

CVE-2019-25090 is a low-severity cross-site scripting vulnerability in Sangoma Freepbx, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in FreePBX arimanager up to 13.0.5.3 and classified as problematic. Affected by this issue is some unknown functionality of the component Views Handler. The manipulation of the argument dataurl leads to cross site scripting. The attack may be launched remotely. Upgrading to version 13.0.5.4 is able to address this issue. The name of the patch is 199dea7cc7020d3c469a86a39fbd80f5edd3c5ab. It is recommended to upgrade the affected component. VDB-216878 is the identifier assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2019-25090?

It affects 1 product.

Products include Sangoma Freepbx.

How do I fix CVE-2019-25090?

No fix has been published for CVE-2019-25090 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-25090 being exploited?

There is no known exploitation of CVE-2019-25090 in the wild and no public exploit code.

All Sangoma Freepbx vulnerabilities

Sources

Also known as GHSA-rphx-h6qg-2rqj.

Is CVE-2019-25090 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free