# CVE-2019-25092: Nakiami Mellivora Admin Panel user.inc.php print_user_ip_log cross site scripting

> Remote attackers can inject malicious scripts via the IP log in the Mellivora admin panel, potentially compromising user sessions.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-jr9c-c5m3-29r9

## What is CVE-2019-25092?

CVE-2019-25092 is a low-severity cross-site scripting vulnerability in Nakiami Mellivora, published on 28 Dec 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic was found in Nakiami Mellivora up to 2.1.x. Affected by this vulnerability is the function print_user_ip_log of the file include/layout/user.inc.php of the component Admin Panel. The manipulation of the argument $entry['ip'] leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.2.0 is able to address this issue. The name of the patch is e0b6965f8dde608a3d2621617c05695eb406cbb9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216955.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-25092?

It affects 1 product.


Products: Mellivora Project Mellivora.

## How do I fix CVE-2019-25092?

No fix has been published for CVE-2019-25092 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-25092 being exploited?

There is no known exploitation of CVE-2019-25092 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25092 and fix it if it is affected.

What it is: CVE-2019-25092 is a low-severity cross-site scripting vulnerability in Nakiami Mellivora, published on 28 Dec 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-25092 in the wild and no public exploit code.

Affected product: Nakiami Mellivora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25092/ (Markdown: https://insights.sbomify.com/CVE-2019-25092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25092
- OSV: https://osv.dev/vulnerability/CVE-2019-25092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25092/
Summaries are generated and may contain mistakes; the official description above is the record.
