{"answers":{"affected":"2 open source packages ship an affected version, including innologi/typo3-appointments. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25094 in the wild and no public exploit code.","fix":"Upgrade innologi/typo3-appointments to 2.0.6 or later.","what":"CVE-2019-25094 is a low-severity cross-site scripting vulnerability in innologi appointments Extension, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-25094 and fix it if it is affected.\n\nWhat it is: CVE-2019-25094 is a low-severity cross-site scripting vulnerability in innologi appointments Extension, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-25094 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- innologi/typo3-appointments (Packagist): affected all versions; fixed in 2.0.6\n- innologi/typo3-appointments (Packagist): affected all versions; fixed in 2.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25094/ (Markdown: https://insights.sbomify.com/CVE-2019-25094/index.md)","id":"CVE-2019-25094","markdown":"https://insights.sbomify.com/CVE-2019-25094/index.md","name":"CVE-2019-25094","record":{"aliases":["GHSA-cf5r-3pvm-w64w"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 appointments extension","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the formfield argument in the TYPO3 appointments extension, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"appointment_scheduler","vendor":"innologi"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5 on TYPO3. This affects an unknown part of the component Appointment Handler. The manipulation of the argument formfield leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.6 is able to address this issue. The identifier of the patch is 986d3cb34e5e086c6f04e061f600ffc5837abe7f. It is recommended to upgrade the affected component. The identifier VDB-217353 was assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"innologi appointments Extension Appointment cross site scripting","id":"CVE-2019-25094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"kakwa LdapCherry URL cross site scripting","id":"CVE-2019-25095"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.6"],"introduced":["0"],"last_affected":[],"package":"innologi/typo3-appointments","purl":null,"source":"GHSA-cf5r-3pvm-w64w"},{"ecosystem":"Packagist","fixed":["2.0.6"],"introduced":["0"],"last_affected":[],"package":"innologi/typo3-appointments","purl":"pkg:composer/innologi/typo3-appointments","source":"GHSA-cf5r-3pvm-w64w"}],"prev":{"headline":"dragonexpert Recent Threads on Index Setting hooks.php recentthread_list_threads cross site scripting","id":"CVE-2019-25093"},"products":["appointments Extension"],"published":"2023-01-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["innologi"]},"summary":"Remote attackers can inject malicious scripts via the formfield argument in the TYPO3 appointments extension, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2019-25094/"}