# CVE-2019-25094: innologi appointments Extension Appointment cross site scripting

> Remote attackers can inject malicious scripts via the formfield argument in the TYPO3 appointments extension, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cf5r-3pvm-w64w

## What is CVE-2019-25094?

CVE-2019-25094 is a low-severity cross-site scripting vulnerability in innologi appointments Extension, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5 on TYPO3. This affects an unknown part of the component Appointment Handler. The manipulation of the argument formfield leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.6 is able to address this issue. The identifier of the patch is 986d3cb34e5e086c6f04e061f600ffc5837abe7f. It is recommended to upgrade the affected component. The identifier VDB-217353 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-25094?

2 open source packages ship an affected version, including innologi/typo3-appointments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `innologi/typo3-appointments` | Packagist | All versions | 2.0.6 |
| `innologi/typo3-appointments` | Packagist | All versions | 2.0.6 |

Products: Innologi Appointment Scheduler.

## How do I fix CVE-2019-25094?

Upgrade innologi/typo3-appointments to 2.0.6 or later.

## Is CVE-2019-25094 being exploited?

There is no known exploitation of CVE-2019-25094 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25094 and fix it if it is affected.

What it is: CVE-2019-25094 is a low-severity cross-site scripting vulnerability in innologi appointments Extension, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-25094 in the wild and no public exploit code.

Affected packages and fixed versions:
- innologi/typo3-appointments (Packagist): affected all versions; fixed in 2.0.6
- innologi/typo3-appointments (Packagist): affected all versions; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25094/ (Markdown: https://insights.sbomify.com/CVE-2019-25094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25094
- OSV: https://osv.dev/vulnerability/CVE-2019-25094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25094/
Summaries are generated and may contain mistakes; the official description above is the record.
