{"answers":{"affected":"3 open source packages ship an affected version, including ldapcherry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25095 in the wild and no public exploit code.","fix":"Upgrade ldapcherry to 1.0.0 or later.","what":"CVE-2019-25095 is a low-severity cross-site scripting vulnerability in kakwa LdapCherry, published on 5 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-25095 and fix it if it is affected.\n\nWhat it is: CVE-2019-25095 is a low-severity cross-site scripting vulnerability in kakwa LdapCherry, published on 5 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-25095 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ldapcherry (PyPI): affected all versions; fixed in 1.0.0\n- ldapcherry (PyPI): affected all versions; fixed in 1.0.0\n- ldapcherry (PyPI): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25095/ (Markdown: https://insights.sbomify.com/CVE-2019-25095/index.md)","id":"CVE-2019-25095","markdown":"https://insights.sbomify.com/CVE-2019-25095/index.md","name":"CVE-2019-25095","record":{"aliases":["GHSA-vq8w-x8v7-f88m","PYSEC-2023-19"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LDAP management tool","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the URL handler in kakwa LdapCherry, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ldapcherry","vendor":"ldapcherry_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in kakwa LdapCherry up to 0.x. Affected is an unknown function of the component URL Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 6f98076281e9452fdb1adcd1bcbb70a6f968ade9. It is recommended to upgrade the affected component. VDB-217434 is the identifier assigned to this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"kakwa LdapCherry URL cross site scripting","id":"CVE-2019-25095","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":3,"n_references":5,"next":{"headline":"soerennb eXtplorer cross site scripting","id":"CVE-2019-25096"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ldapcherry","purl":null,"source":"GHSA-vq8w-x8v7-f88m"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ldapcherry","purl":"pkg:pypi/ldapcherry","source":"GHSA-vq8w-x8v7-f88m"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ldapcherry","purl":"pkg:pypi/ldapcherry","source":"PYSEC-2023-19"}],"prev":{"headline":"innologi appointments Extension Appointment cross site scripting","id":"CVE-2019-25094"},"products":["LdapCherry"],"published":"2023-01-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["kakwa"]},"summary":"Remote attackers can inject malicious scripts via the URL handler in kakwa LdapCherry, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2019-25095/"}