CVE-2019-25098 soerennb eXtplorer Archive archive.php path traversal

Medium 5.5 Published Updated

Attackers can exploit a path traversal vulnerability in the archive handler to read or modify arbitrary files on the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2019-25098?

CVE-2019-25098 is a medium-severity path traversal vulnerability in soerennb eXtplorer, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in soerennb eXtplorer up to 2.1.12. It has been classified as critical. This affects an unknown part of the file include/archive.php of the component Archive Handler. The manipulation leads to path traversal. Upgrading to version 2.1.13 is able to address this issue. The identifier of the patch is b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The identifier VDB-217437 was assigned to this vulnerability.

Weakness: CWE-22

Which versions are affected by CVE-2019-25098?

It affects 1 product.

Products include Extplorer Extplorer.

How do I fix CVE-2019-25098?

No fix has been published for CVE-2019-25098 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2019-25098 being exploited?

There is no known exploitation of CVE-2019-25098 in the wild and no public exploit code.

Sources

Also known as GHSA-mj4g-q8gh-hp8q, UBUNTU-CVE-2019-25098.

Is CVE-2019-25098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free