{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25098 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-25098 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-25098 is a medium-severity path traversal vulnerability in soerennb eXtplorer, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-25098 and fix it if it is affected.\n\nWhat it is: CVE-2019-25098 is a medium-severity path traversal vulnerability in soerennb eXtplorer, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-25098 in the wild and no public exploit code.\n\nAffected product: soerennb eXtplorer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25098/ (Markdown: https://insights.sbomify.com/CVE-2019-25098/index.md)","id":"CVE-2019-25098","markdown":"https://insights.sbomify.com/CVE-2019-25098/index.md","name":"CVE-2019-25098","record":{"aliases":["GHSA-mj4g-q8gh-hp8q","UBUNTU-CVE-2019-25098"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"eXtplorer file manager","requires_auth":"low_privilege","summary":"Attackers can exploit a path traversal vulnerability in the archive handler to read or modify arbitrary files on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"extplorer","vendor":"extplorer"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability was found in soerennb eXtplorer up to 2.1.12. It has been classified as critical. This affects an unknown part of the file include/archive.php of the component Archive Handler. The manipulation leads to path traversal. Upgrading to version 2.1.13 is able to address this issue. The identifier of the patch is b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The identifier VDB-217437 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"soerennb eXtplorer Archive archive.php path traversal","id":"CVE-2019-25098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":0,"n_references":4,"next":{"headline":"Arthmoor QSF-Portal index.php path traversal","id":"CVE-2019-25099"},"packages":[],"prev":{"headline":"soerennb eXtplorer Directory Content path traversal","id":"CVE-2019-25097"},"products":["eXtplorer"],"published":"2023-01-05","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2012-6710","kev_date_added":null,"published":"2018-10-07"},{"cvss_score":9.3,"headline":"eXtplorer\u003c= 2.1.14 - Authentication Bypass \u0026 Remote Code Execution (RCE)","id":"CVE-2023-54335","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":8.8,"headline":"File upload in n/a","id":"CVE-2023-29657","kev_date_added":null,"published":"2023-05-12"},{"cvss_score":8.8,"headline":"Missing authorization in n/a","id":"CVE-2023-27842","kev_date_added":null,"published":"2023-03-21"},{"cvss_score":7.8,"headline":"Path traversal in n/a","id":"CVE-2016-4313","kev_date_added":null,"published":"2017-04-24"},{"cvss_score":7.2,"headline":"Command injection in n/a","id":"CVE-2017-12756","kev_date_added":null,"published":"2017-08-09"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2015-5660","kev_date_added":null,"published":"2015-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["soerennb"]},"summary":"Attackers can exploit a path traversal vulnerability in the archive handler to read or modify arbitrary files on the server.","url":"https://insights.sbomify.com/CVE-2019-25098/"}