{"answers":{"affected":"2 open source packages ship an affected version, including simple-markdown. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-25102 in the wild and no public exploit code.","fix":"Upgrade simple-markdown to 0.6.1 or later.","what":"CVE-2019-25102 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-25102 and fix it if it is affected.\n\nWhat it is: CVE-2019-25102 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-25102 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simple-markdown (npm): affected all versions; fixed in 0.6.1\n- simple-markdown (npm): affected all versions; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-25102/ (Markdown: https://insights.sbomify.com/CVE-2019-25102/index.md)","id":"CVE-2019-25102","markdown":"https://insights.sbomify.com/CVE-2019-25102/index.md","name":"CVE-2019-25102","record":{"aliases":["GHSA-j533-2g8v-pmpg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript markdown library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in simple-markdown via inefficient regular expression complexity, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"simple-markdown","vendor":"khanacademy"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability, which was classified as problematic, was found in simple-markdown 0.6.0. Affected is an unknown function of the file simple-markdown.js. The manipulation with the input \u003c\u003c\u003c\u003c\u003c\u003c\u003c\u003c\u003c\u003c:/:/:/:/:/:/:/:/:/:/ leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.6.1 is able to address this issue. The patch is identified as 015a719bf5cdc561feea05500ecb3274ef609cd2. It is recommended to upgrade the affected component. VDB-220638 is the identifier assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"simple-markdown simple-markdown.js redos","id":"CVE-2019-25102","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":5,"next":{"headline":"simple-markdown simple-markdown.js redos","id":"CVE-2019-25103"},"packages":[{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"simple-markdown","purl":null,"source":"GHSA-j533-2g8v-pmpg"},{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"simple-markdown","purl":"pkg:npm/simple-markdown","source":"GHSA-j533-2g8v-pmpg"}],"prev":{"headline":"OnShift TurboGears HTTP Header controllers.py response splitting","id":"CVE-2019-25101"},"products":["simple-markdown"],"published":"2023-02-12","related":[{"cvss_score":4.3,"headline":"simple-markdown simple-markdown.js redos","id":"CVE-2019-25103","kev_date_added":null,"published":"2023-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in simple-markdown via inefficient regular expression complexity, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2019-25102/"}