# CVE-2019-25102: simple-markdown simple-markdown.js redos

> Remote attackers can cause denial of service in simple-markdown via inefficient regular expression complexity, requiring an upgrade to fix.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j533-2g8v-pmpg

## What is CVE-2019-25102?

CVE-2019-25102 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, was found in simple-markdown 0.6.0. Affected is an unknown function of the file simple-markdown.js. The manipulation with the input <<<<<<<<<<:/:/:/:/:/:/:/:/:/:/ leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.6.1 is able to address this issue. The patch is identified as 015a719bf5cdc561feea05500ecb3274ef609cd2. It is recommended to upgrade the affected component. VDB-220638 is the identifier assigned to this vulnerability.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2019-25102?

2 open source packages ship an affected version, including simple-markdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-markdown` | npm | All versions | 0.6.1 |
| `simple-markdown` | npm | All versions | 0.6.1 |

Products: Khanacademy Simple-Markdown.

## How do I fix CVE-2019-25102?

Upgrade simple-markdown to 0.6.1 or later.

## Is CVE-2019-25102 being exploited?

There is no known exploitation of CVE-2019-25102 in the wild and no public exploit code.

## Other vulnerabilities in simple-markdown

- [CVE-2019-25103](https://insights.sbomify.com/CVE-2019-25103/): simple-markdown simple-markdown.js redos (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25102 and fix it if it is affected.

What it is: CVE-2019-25102 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25102 in the wild and no public exploit code.

Affected packages and fixed versions:
- simple-markdown (npm): affected all versions; fixed in 0.6.1
- simple-markdown (npm): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25102/ (Markdown: https://insights.sbomify.com/CVE-2019-25102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25102
- OSV: https://osv.dev/vulnerability/CVE-2019-25102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25102/
Summaries are generated and may contain mistakes; the official description above is the record.
