CVE-2019-25103 simple-markdown simple-markdown.js redos

Medium 4.3 Published Updated

Remote attackers can cause denial of service in simple-markdown via inefficient regular expression complexity, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-25103?

CVE-2019-25103 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability has been found in simple-markdown 0.5.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file simple-markdown.js. The manipulation leads to inefficient regular expression complexity. The attack can be launched remotely. Upgrading to version 0.5.2 is able to address this issue. The patch is named 89797fef9abb4cab2fb76a335968266a92588816. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220639.

Weakness: CWE-1333

Which versions are affected by CVE-2019-25103?

2 open source packages ship an affected version, including simple-markdown. It affects 1 product.

PackageAffectedFixed in
simple-markdown npmAll versions0.5.2
simple-markdown npmAll versions0.5.2

Products include Khanacademy Simple-Markdown.

How do I fix CVE-2019-25103?

Upgrade simple-markdown to 0.5.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-25103 being exploited?

There is no known exploitation of CVE-2019-25103 in the wild and no public exploit code.

Sources

Also known as GHSA-gpvj-gp8c-c7p2.

Is CVE-2019-25103 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free