# CVE-2019-25103: simple-markdown simple-markdown.js redos

> Remote attackers can cause denial of service in simple-markdown via inefficient regular expression complexity, requiring an upgrade to fix.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gpvj-gp8c-c7p2

## What is CVE-2019-25103?

CVE-2019-25103 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in simple-markdown 0.5.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file simple-markdown.js. The manipulation leads to inefficient regular expression complexity. The attack can be launched remotely. Upgrading to version 0.5.2 is able to address this issue. The patch is named 89797fef9abb4cab2fb76a335968266a92588816. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220639.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2019-25103?

2 open source packages ship an affected version, including simple-markdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-markdown` | npm | All versions | 0.5.2 |
| `simple-markdown` | npm | All versions | 0.5.2 |

Products: Khanacademy Simple-Markdown.

## How do I fix CVE-2019-25103?

Upgrade simple-markdown to 0.5.2 or later.

## Is CVE-2019-25103 being exploited?

There is no known exploitation of CVE-2019-25103 in the wild and no public exploit code.

## Other vulnerabilities in simple-markdown

- [CVE-2019-25102](https://insights.sbomify.com/CVE-2019-25102/): simple-markdown simple-markdown.js redos (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25103 and fix it if it is affected.

What it is: CVE-2019-25103 is a medium-severity denial of service vulnerability in simple-markdown, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25103 in the wild and no public exploit code.

Affected packages and fixed versions:
- simple-markdown (npm): affected all versions; fixed in 0.5.2
- simple-markdown (npm): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25103/ (Markdown: https://insights.sbomify.com/CVE-2019-25103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25103
- OSV: https://osv.dev/vulnerability/CVE-2019-25103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25103/
Summaries are generated and may contain mistakes; the official description above is the record.
