# CVE-2019-25142: Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update

> Authenticated attackers can modify restricted WordPress options in Mesmerize and Materialis themes due to insufficient authorization checks.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jun 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-w4h9-w7jf-x53v

## What is CVE-2019-25142?

CVE-2019-25142 is a high-severity missing authorization vulnerability in extendthemes Materialis, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Mesmerize & Materialis themes for WordPress are vulnerable to authenticated options change in versions up to, and including,1.6.89 (Mesmerize) and 1.0.172 (Materialis). This is due to 'companion_disable_popup' function only checking the nonce while sending user input to the 'update_option' function. This makes it possible for authenticated attackers to change otherwise restricted options.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-25142?

It affects 2 products.


Products: Extendthemes Materialis, Extendthemes Mesmerize.

## How do I fix CVE-2019-25142?

No fix has been published for CVE-2019-25142 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-25142 being exploited?

There is no known exploitation of CVE-2019-25142 in the wild and no public exploit code.

## Other vulnerabilities in extendthemes Materialis

- [CVE-2023-3204](https://insights.sbomify.com/CVE-2023-3204/): Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25142 and fix it if it is affected.

What it is: CVE-2019-25142 is a high-severity missing authorization vulnerability in extendthemes Materialis, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25142 in the wild and no public exploit code.

Affected product: extendthemes Materialis. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25142/ (Markdown: https://insights.sbomify.com/CVE-2019-25142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25142
- OSV: https://osv.dev/vulnerability/CVE-2019-25142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25142/
Summaries are generated and may contain mistakes; the official description above is the record.
