# CVE-2019-25158: pedroetb tts-api app.js onSpeechDone os command injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 19 Dec 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jx6q-fq9h-6g7q

## What is CVE-2019-25158?

CVE-2019-25158 is a medium-severity vulnerability in pedroetb tts-api, published on 19 Dec 2023. 

### Official description

A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-25158?

2 open source packages ship an affected version, including tts-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tts-api` | npm | All versions | 2.2.0 |
| `tts-api` | npm | All versions | 2.2.0 |

Products: Pedroetb Tts-Api.

## How do I fix CVE-2019-25158?

Upgrade tts-api to 2.2.0 or later.

## Is CVE-2019-25158 being exploited?

There is no known exploitation of CVE-2019-25158 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25158 and fix it if it is affected.

What it is: CVE-2019-25158 is a medium-severity vulnerability in pedroetb tts-api, published on 19 Dec 2023. 
Exploitation: There is no known exploitation of CVE-2019-25158 in the wild and no public exploit code.

Affected packages and fixed versions:
- tts-api (npm): affected all versions; fixed in 2.2.0
- tts-api (npm): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25158/ (Markdown: https://insights.sbomify.com/CVE-2019-25158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25158
- OSV: https://osv.dev/vulnerability/CVE-2019-25158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25158/
Summaries are generated and may contain mistakes; the official description above is the record.
