# CVE-2019-25159: mpedraza2020 Intranet del Monterroso cargos.php sql injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 4 Feb 2024
- **Updated:** 15 May 2025
- **Also known as:** GHSA-mhh5-gvh7-h426

## What is CVE-2019-25159?

CVE-2019-25159 is a medium-severity vulnerability in mpedraza2020 Intranet del Monterroso, published on 4 Feb 2024. 

### Official description

A vulnerability was found in mpedraza2020 Intranet del Monterroso up to 4.50.0. It has been classified as critical. This affects an unknown part of the file config/cargos.php. The manipulation of the argument dni_profe leads to sql injection. Upgrading to version 4.51.0 is able to address this issue. The identifier of the patch is 678190bee1dfd64b54a2b0e88abfd009e78adce8. It is recommended to upgrade the affected component. The identifier VDB-252717 was assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-25159?

It affects 1 product.


Products: Mpedraza2020 Intranet Del Monterroso.

## How do I fix CVE-2019-25159?

No fix has been published for CVE-2019-25159 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-25159 being exploited?

There is no known exploitation of CVE-2019-25159 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25159 and fix it if it is affected.

What it is: CVE-2019-25159 is a medium-severity vulnerability in mpedraza2020 Intranet del Monterroso, published on 4 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2019-25159 in the wild and no public exploit code.

Affected product: mpedraza2020 Intranet del Monterroso. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25159/ (Markdown: https://insights.sbomify.com/CVE-2019-25159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25159
- OSV: https://osv.dev/vulnerability/CVE-2019-25159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25159/
Summaries are generated and may contain mistakes; the official description above is the record.
