# CVE-2019-25211: Gin mishandles a wildcard at the end of an origin string

> The Gin-Gonic CORS middleware incorrectly validates wildcard origins, allowing attackers to bypass Cross-Origin Resource Sharing restrictions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2019-25211, DLA-4285-1, GHSA-869c-j7wc-8jqv, GO-2024-2955, UBUNTU-CVE-2019-25211

## What is CVE-2019-25211?

CVE-2019-25211 is a critical vulnerability in n/a, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

parseWildcardRules in Gin-Gonic CORS middleware before 1.6.0 mishandles a wildcard at the end of an origin string, e.g., https://example.community/* is allowed when the intention is that only https://example.com/* should be allowed, and http://localhost.example.com/* is allowed when the intention is that only http://localhost/* should be allowed.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2019-25211?

5 open source packages ship an affected version, including github.com/gin-contrib/cors and github.com/gin-gonic/gin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gin-contrib/cors` | Go | All versions | 1.6.0 |
| `github.com/gin-contrib/cors` | Go | All versions | 1.6.0 |
| `github.com/gin-contrib/cors` | Go | All versions | 1.6.0 |
| `github.com/gin-gonic/gin` | Go | All versions | 1.6.0 |
| `github.com/gin-gonic/gin` | Go | All versions | 1.6.0 |

## How do I fix CVE-2019-25211?

Upgrade github.com/gin-contrib/cors to 1.6.0 or later.

## Is CVE-2019-25211 being exploited?

There is no known exploitation of CVE-2019-25211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25211 and fix it if it is affected.

What it is: CVE-2019-25211 is a critical vulnerability in n/a, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25211 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gin-contrib/cors (Go): affected all versions; fixed in 1.6.0
- github.com/gin-contrib/cors (Go): affected all versions; fixed in 1.6.0
- github.com/gin-contrib/cors (Go): affected all versions; fixed in 1.6.0
- github.com/gin-gonic/gin (Go): affected all versions; fixed in 1.6.0
- github.com/gin-gonic/gin (Go): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25211/ (Markdown: https://insights.sbomify.com/CVE-2019-25211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25211
- OSV: https://osv.dev/vulnerability/CVE-2019-25211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25211/
Summaries are generated and may contain mistakes; the official description above is the record.
