# CVE-2019-25225: sanitize-html is vulnerable to XSS through incomprehensive sanitization

> Attackers can execute arbitrary scripts via malicious input when using the custom transformTags option in the sanitize-html library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** CLSA-2026-1775003160, GHSA-qhxp-v273-g94h, ROOT-APP-NPM-CVE-2019-25225, UBUNTU-CVE-2019-25225

## What is CVE-2019-25225?

CVE-2019-25225 is a medium-severity cross-site scripting vulnerability in apostrophecms:sanitize-html, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

`sanitize-html` prior to version 2.0.0-beta is vulnerable to Cross-site Scripting (XSS). The `sanitizeHtml()` function in `index.js` does not sanitize content when using the custom `transformTags` option, which is intended to convert attribute values into text. As a result, malicious input can be transformed into executable code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-25225?

2 open source packages ship an affected version, including sanitize-html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 2.0.0-beta |
| `sanitize-html` | npm | All versions | 2.0.0-beta |

Products: Apostrophecms Sanitize-Html.

## How do I fix CVE-2019-25225?

Upgrade sanitize-html to 2.0.0-beta or later.

## Is CVE-2019-25225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-25225 exists.

## Other vulnerabilities in apostrophecms:sanitize-html

- [CVE-2014-125128](https://insights.sbomify.com/CVE-2014-125128/): Cross-site scripting in apostrophecms:sanitize-html (medium 6.1)
- [CVE-2016-1000237](https://insights.sbomify.com/CVE-2016-1000237/): Cross-Site Scripting in sanitize-html (medium 6.1)
- [CVE-2024-21501](https://insights.sbomify.com/CVE-2024-21501/): sanitize-html Information Exposure vulnerability (medium 5.3)
- [CVE-2022-25887](https://insights.sbomify.com/CVE-2022-25887/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-26539](https://insights.sbomify.com/CVE-2021-26539/): Improper Input Validation in sanitize-html (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25225 and fix it if it is affected.

What it is: CVE-2019-25225 is a medium-severity cross-site scripting vulnerability in apostrophecms:sanitize-html, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-25225 exists.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 2.0.0-beta
- sanitize-html (npm): affected all versions; fixed in 2.0.0-beta

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25225/ (Markdown: https://insights.sbomify.com/CVE-2019-25225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25225
- OSV: https://osv.dev/vulnerability/CVE-2019-25225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25225/
Summaries are generated and may contain mistakes; the official description above is the record.
