# CVE-2019-25317: Kimai 2- persistent cross-site scripting (XSS)

> Attackers can inject malicious scripts into timesheet descriptions, leading to arbitrary JavaScript execution when viewed by other users.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-9278-6hcj-2p4j

## What is CVE-2019-25317?

CVE-2019-25317 is a medium-severity cross-site scripting vulnerability in kevinpapst Kimai, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kimai 2 contains a persistent cross-site scripting vulnerability that allows attackers to inject malicious scripts into timesheet descriptions. Attackers can insert SVG-based XSS payloads in the description field to execute arbitrary JavaScript when the page is loaded and viewed by other users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-25317?

2 open source packages ship an affected version, including kimai/kimai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 1.1 |
| `kimai/kimai` | Packagist | All versions | 1.1 |

Products: Kimai Kimai.

## How do I fix CVE-2019-25317?

Upgrade kimai/kimai to 1.1 or later.

## Is CVE-2019-25317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-25317 exists.

## Other vulnerabilities in kevinpapst Kimai

- [CVE-2020-19825](https://insights.sbomify.com/CVE-2020-19825/): Cross-site Scripting in kimai/kimai (critical 9.6)
- [CVE-2023-53957](https://insights.sbomify.com/CVE-2023-53957/): Kimai 1.30.10 SameSite Cookie Vulnerability Session Hijacking (high 8.5)
- [CVE-2021-43515](https://insights.sbomify.com/CVE-2021-43515/): Improper Neutralization of Formula Elements in a CSV File in Kimai 2 (high 7.8)
- [CVE-2023-46245](https://insights.sbomify.com/CVE-2023-46245/): Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File (high 7.2)
- [CVE-2026-23626](https://insights.sbomify.com/CVE-2026-23626/): Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI) (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25317 and fix it if it is affected.

What it is: CVE-2019-25317 is a medium-severity cross-site scripting vulnerability in kevinpapst Kimai, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-25317 exists.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 1.1
- kimai/kimai (Packagist): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25317/ (Markdown: https://insights.sbomify.com/CVE-2019-25317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25317
- OSV: https://osv.dev/vulnerability/CVE-2019-25317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25317/
Summaries are generated and may contain mistakes; the official description above is the record.
