# CVE-2019-25766: Renovate before 19.38.7 Credential Exposure via Go Modules

> Renovate leaks temporary repository tokens in pull request comments during Go Modules failures, allowing attackers to access private repositories.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-3r27-cgcx-x497, GHSA-v7x3-7hw7-pcjg

## What is CVE-2019-25766?

CVE-2019-25766 is a high-severity vulnerability in renovatebot renovate, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Renovate versions >= 13.87.0 and <= 19.38.6 leak temporary repository tokens into pull request comments during certain Go Modules update failure scenarios. The issue is fixed in version 19.38.7. Anyone able to view the affected pull request comments could obtain the exposed tokens.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2019-25766?

2 open source packages ship an affected version, including renovate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `renovate` | npm | From 13.87.0 | 19.38.7 |
| `renovate` | npm | From 13.87.0 | 19.38.7 |

## How do I fix CVE-2019-25766?

Upgrade renovate to 19.38.7 or later.

## Is CVE-2019-25766 being exploited?

There is no known exploitation of CVE-2019-25766 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-25766 and fix it if it is affected.

What it is: CVE-2019-25766 is a high-severity vulnerability in renovatebot renovate, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-25766 in the wild and no public exploit code.

Affected packages and fixed versions:
- renovate (npm): affected from 13.87.0; fixed in 19.38.7
- renovate (npm): affected from 13.87.0; fixed in 19.38.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-25766/ (Markdown: https://insights.sbomify.com/CVE-2019-25766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-25766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-25766
- OSV: https://osv.dev/vulnerability/CVE-2019-25766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-25766/
Summaries are generated and may contain mistakes; the official description above is the record.
