CVE-2019-3394 Path traversal in Confluence Server
An attacker with page editing permissions can exploit a path traversal flaw to read arbitrary files, potentially leaking sensitive configuration data and credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2019-3394?
CVE-2019-3394 is a high-severity path traversal vulnerability in Atlassian Confluence Server, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-directory>/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.
Weakness: CWE-22
Which versions are affected by CVE-2019-3394?
It affects 2 products.
Products include Atlassian Confluence, Atlassian Confluence Server.
How do I fix CVE-2019-3394?
No fix has been published for CVE-2019-3394 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-3394 being exploited?
There is no known exploitation of CVE-2019-3394 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Atlassian Confluence Server
Sources
Also known as GHSA-3qjw-wqhv-r92w.