{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-3394 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-3394 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-3394 is a high-severity path traversal vulnerability in Atlassian Confluence Server, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-3394 and fix it if it is affected.\n\nWhat it is: CVE-2019-3394 is a high-severity path traversal vulnerability in Atlassian Confluence Server, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-3394 in the wild and no public exploit code.\n\nAffected product: Atlassian Confluence Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-3394/ (Markdown: https://insights.sbomify.com/CVE-2019-3394/index.md)","id":"CVE-2019-3394","markdown":"https://insights.sbomify.com/CVE-2019-3394/index.md","name":"CVE-2019-3394","record":{"aliases":["GHSA-3qjw-wqhv-r92w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Confluence Server","requires_auth":"low_privilege","summary":"An attacker with page editing permissions can exploit a path traversal flaw to read arbitrary files, potentially leaking sensitive configuration data and credentials.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"atlassian","cpe":[{"product":"confluence","vendor":"atlassian"},{"product":"confluence_server","vendor":"atlassian"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under \u003cinstall-directory\u003e/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2019-08-30","github_poc":1,"max_poc_stars":17,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-08-30T07:44:17Z","kind":"github_poc","ref":"https://github.com/jas502n/CVE-2019-3394","stars":17,"title":"Confluence（\u003cinstall-directory\u003e/confluence/WEB-INF/）文件读取漏洞"}],"tier":"poc_unverified"},"has_fix":null,"headline":"Path traversal in Confluence Server","id":"CVE-2019-3394","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":0,"n_references":2,"next":{"headline":"Server-side request forgery in Confluence Server","id":"CVE-2019-3395"},"packages":[],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is mistakenly published by the other party.","id":"CVE-2019-3309"},"products":["Confluence Server"],"published":"2019-08-29","related":[{"cvss_score":9.8,"headline":"Server-side request forgery in Confluence Server","id":"CVE-2019-3395","kev_date_added":null,"published":"2019-03-25"},{"cvss_score":7.8,"headline":"Privilege escalation in Confluence Data Center","id":"CVE-2019-20406","kev_date_added":null,"published":"2020-02-06"},{"cvss_score":6.5,"headline":"Other in Confluence Server","id":"CVE-2019-15006","kev_date_added":null,"published":"2019-12-19"},{"cvss_score":6.1,"headline":"Cross-site scripting in Confluence","id":"CVE-2017-18085","kev_date_added":null,"published":"2018-02-02"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-18086","kev_date_added":null,"published":"2018-02-02"},{"cvss_score":6.1,"headline":"Cross-site scripting in Confluence","id":"CVE-2017-16856","kev_date_added":null,"published":"2017-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Atlassian"]},"summary":"An attacker with page editing permissions can exploit a path traversal flaw to read arbitrary files, potentially leaking sensitive configuration data and credentials.","url":"https://insights.sbomify.com/CVE-2019-3394/"}