# CVE-2019-3394: Path traversal in Confluence Server

> An attacker with page editing permissions can exploit a path traversal flaw to read arbitrary files, potentially leaking sensitive configuration data and credentials.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Aug 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3qjw-wqhv-r92w

## What is CVE-2019-3394?

CVE-2019-3394 is a high-severity path traversal vulnerability in Atlassian Confluence Server, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-directory>/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-3394?

It affects 2 products.


Products: Atlassian Confluence, Atlassian Confluence Server.

## How do I fix CVE-2019-3394?

No fix has been published for CVE-2019-3394 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-3394 being exploited?

There is no known exploitation of CVE-2019-3394 in the wild and no public exploit code.

Public exploit code:

- Confluence（<install-directory>/confluence/WEB-INF/）文件读取漏洞 (github_poc): https://github.com/jas502n/CVE-2019-3394

## Other vulnerabilities in Atlassian Confluence Server

- [CVE-2019-3395](https://insights.sbomify.com/CVE-2019-3395/): Server-side request forgery in Confluence Server (critical 9.8)
- [CVE-2019-20406](https://insights.sbomify.com/CVE-2019-20406/): Privilege escalation in Confluence Data Center (high 7.8)
- [CVE-2019-15006](https://insights.sbomify.com/CVE-2019-15006/): Other in Confluence Server (medium 6.5)
- [CVE-2017-18085](https://insights.sbomify.com/CVE-2017-18085/): Cross-site scripting in Confluence (medium 6.1)
- [CVE-2017-18086](https://insights.sbomify.com/CVE-2017-18086/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3394 and fix it if it is affected.

What it is: CVE-2019-3394 is a high-severity path traversal vulnerability in Atlassian Confluence Server, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-3394 in the wild and no public exploit code.

Affected product: Atlassian Confluence Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3394/ (Markdown: https://insights.sbomify.com/CVE-2019-3394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3394
- OSV: https://osv.dev/vulnerability/CVE-2019-3394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3394/
Summaries are generated and may contain mistakes; the official description above is the record.
