CVE-2019-3396 Atlassian Confluence Server and Data Center Server-Side Template Injection
Remote attackers can achieve path traversal and remote code execution on Confluence Server via server-side template injection in the Widget Connector macro.
- Exploited in the wild
- Since 3 Nov 2021
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2019-3396?
CVE-2019-3396 is a critical path traversal vulnerability in Atlassian Confluence Server, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.
Weakness: CWE-22
Which versions are affected by CVE-2019-3396?
It affects 1 product.
Products include Atlassian Confluence Server.
How do I fix CVE-2019-3396?
No fix has been published for CVE-2019-3396 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 3 May 2022.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-3396 being exploited?
Yes. Attackers have exploited CVE-2019-3396 in the wild since at least 3 Nov 2021, including in ransomware campaigns.
Public exploit code: 1 Metasploit module, 3 Exploit-DB entries, 1 Nuclei template and 22 proofs of concept on GitHub.
Other vulnerabilities in Atlassian Confluence Server
Sources
Also known as GHSA-fr34-8fhg-2m6q.