# CVE-2019-3396: Atlassian Confluence Server and Data Center Server-Side Template Injection

> Remote attackers can achieve path traversal and remote code execution on Confluence Server via server-side template injection in the Widget Connector macro.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Mar 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-fr34-8fhg-2m6q

## What is CVE-2019-3396?

CVE-2019-3396 is a critical path traversal vulnerability in Atlassian Confluence Server, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-3396?

It affects 1 product.


Products: Atlassian Confluence Server.

## How do I fix CVE-2019-3396?

No fix has been published for CVE-2019-3396 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 3 May 2022.

## Is CVE-2019-3396 being exploited?

Yes. Attackers have exploited CVE-2019-3396 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- CVE-2019-3396 confluence SSTI RCE (github_poc): https://github.com/Yt1g3r/CVE-2019-3396_EXP
- Confluence 未授权 RCE (CVE-2019-3396) 漏洞 (github_poc): https://github.com/jas502n/CVE-2019-3396
- Confluence Widget Connector RCE (github_poc): https://github.com/pyn3rd/CVE-2019-3396
- Confluence Widget Connector path traversal (CVE-2019-3396) (github_poc): https://github.com/x-f1v3/CVE-2019-3396
- https://github.com/0xNinjaCyclone/cve-2019-3396 (github_poc): https://github.com/0xNinjaCyclone/cve-2019-3396
- Confluence unauthorize template injection (github_poc): https://github.com/PetrusViet/cve-2019-3396

## Other vulnerabilities in Atlassian Confluence Server

- [CVE-2019-3398](https://insights.sbomify.com/CVE-2019-3398/): Atlassian Confluence Server and Data Center Path Traversal (high 8.8, exploited in the wild)
- [CVE-2017-7415](https://insights.sbomify.com/CVE-2017-7415/): Auth bypass in n/a (high 7.5)
- [CVE-2016-6668](https://insights.sbomify.com/CVE-2016-6668/): Information disclosure in n/a (high 7.5)
- [CVE-2012-6342](https://insights.sbomify.com/CVE-2012-6342/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2012-2928](https://insights.sbomify.com/CVE-2012-2928/): XML external entity in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3396 and fix it if it is affected.

What it is: CVE-2019-3396 is a critical path traversal vulnerability in Atlassian Confluence Server, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-3396 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected product: Atlassian Confluence Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3396/ (Markdown: https://insights.sbomify.com/CVE-2019-3396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3396
- OSV: https://osv.dev/vulnerability/CVE-2019-3396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3396/
Summaries are generated and may contain mistakes; the official description above is the record.
