{"answers":{"affected":"It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2019-3398 in the wild since at least 3 Nov 2021.","fix":"No fix has been published for CVE-2019-3398 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 3 May 2022.","what":"CVE-2019-3398 is a high-severity path traversal vulnerability in Atlassian Confluence, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-3398 and fix it if it is affected.\n\nWhat it is: CVE-2019-3398 is a high-severity path traversal vulnerability in Atlassian Confluence, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2019-3398 in the wild since at least 3 Nov 2021.\n\nAffected product: Atlassian Confluence. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-3398/ (Markdown: https://insights.sbomify.com/CVE-2019-3398/index.md)","id":"CVE-2019-3398","markdown":"https://insights.sbomify.com/CVE-2019-3398/index.md","name":"CVE-2019-3398","record":{"aliases":["GHSA-qv34-rfhx-fg2q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Confluence Server","requires_auth":"low_privilege","summary":"Remote attackers with attachment or space admin permissions can exploit path traversal to write arbitrary files, leading to remote code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"atlassian","cpe":[{"product":"confluence_server","vendor":"atlassian"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2019-04-20","github_poc":2,"max_poc_stars":15,"metasploit":0,"nuclei":1,"refs":[{"date":"2019-04-20T08:07:49Z","kind":"github_poc","ref":"https://github.com/superevr/cve-2019-3398","stars":15,"title":"Python script to exploit confluence path traversal vulnerability cve-2019-3398"},{"date":"2019-11-12","kind":"exploitdb","ref":"47621","stars":null,"title":"Atlassian Confluence 6.15.1 - Directory Traversal"},{"date":"2024-01-28T09:40:35Z","kind":"github_poc","ref":"https://github.com/132231g/CVE-2019-3398","stars":0,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2019/CVE-2019-3398.yaml","stars":null,"title":"Atlassian Confluence Download Attachments - Remote Code Execution"}],"tier":"exploited"},"has_fix":null,"headline":"Atlassian Confluence Server and Data Center Path Traversal","id":"CVE-2019-3398","indexable":true,"kev":{"dateAdded":"2021-11-03","dueDate":"2022-05-03","knownRansomwareCampaignUse":"Unknown","product":"Confluence Server and Data Center","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Atlassian","vulnerabilityName":"Atlassian Confluence Server and Data Center Path Traversal Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":0,"n_references":6,"next":{"headline":"Missing authorization in Jira","id":"CVE-2019-3399"},"packages":[],"prev":{"headline":"Path traversal in Bitbucket Data Center","id":"CVE-2019-3397"},"products":["Confluence"],"published":"2019-04-18","related":[{"cvss_score":9.8,"headline":"Atlassian Confluence Server and Data Center Server-Side Template Injection","id":"CVE-2019-3396","kev_date_added":"2021-11-03","published":"2019-03-25"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2017-7415","kev_date_added":null,"published":"2017-04-27"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2016-6668","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2012-6342","kev_date_added":null,"published":"2014-05-13"},{"cvss_score":6.4,"headline":"XML external entity in n/a","id":"CVE-2012-2928","kev_date_added":null,"published":"2012-05-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in Confluence Server","id":"CVE-2019-20102","kev_date_added":null,"published":"2020-04-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["Atlassian"]},"summary":"Remote attackers with attachment or space admin permissions can exploit path traversal to write arbitrary files, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2019-3398/"}