# CVE-2019-3398: Atlassian Confluence Server and Data Center Path Traversal

> Remote attackers with attachment or space admin permissions can exploit path traversal to write arbitrary files, leading to remote code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Apr 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-qv34-rfhx-fg2q

## What is CVE-2019-3398?

CVE-2019-3398 is a high-severity path traversal vulnerability in Atlassian Confluence, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-3398?

It affects 1 product.


Products: Atlassian Confluence Server.

## How do I fix CVE-2019-3398?

No fix has been published for CVE-2019-3398 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 3 May 2022.

## Is CVE-2019-3398 being exploited?

Yes. Attackers have exploited CVE-2019-3398 in the wild since at least 3 Nov 2021.

Public exploit code:

- Python script to exploit confluence path traversal vulnerability cve-2019-3398 (github_poc): https://github.com/superevr/cve-2019-3398
- Atlassian Confluence 6.15.1 - Directory Traversal (exploitdb)
- https://github.com/132231g/CVE-2019-3398 (github_poc): https://github.com/132231g/CVE-2019-3398
- Atlassian Confluence Download Attachments - Remote Code Execution (nuclei): http/cves/2019/CVE-2019-3398.yaml

## Other vulnerabilities in Atlassian Confluence

- [CVE-2019-3396](https://insights.sbomify.com/CVE-2019-3396/): Atlassian Confluence Server and Data Center Server-Side Template Injection (critical 9.8, exploited in the wild)
- [CVE-2017-7415](https://insights.sbomify.com/CVE-2017-7415/): Auth bypass in n/a (high 7.5)
- [CVE-2016-6668](https://insights.sbomify.com/CVE-2016-6668/): Information disclosure in n/a (high 7.5)
- [CVE-2012-6342](https://insights.sbomify.com/CVE-2012-6342/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2012-2928](https://insights.sbomify.com/CVE-2012-2928/): XML external entity in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3398 and fix it if it is affected.

What it is: CVE-2019-3398 is a high-severity path traversal vulnerability in Atlassian Confluence, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-3398 in the wild since at least 3 Nov 2021.

Affected product: Atlassian Confluence. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3398/ (Markdown: https://insights.sbomify.com/CVE-2019-3398/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3398
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3398
- OSV: https://osv.dev/vulnerability/CVE-2019-3398

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3398/
Summaries are generated and may contain mistakes; the official description above is the record.
