CVE-2019-3465 Signature validation bypass in XmlSecLibs
An authenticated attacker can bypass cryptographic signature validation to impersonate users or escalate privileges in applications using XmlSecLibs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3465?
CVE-2019-3465 is a high-severity vulnerability in Debian Debian Linux, published on 7 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.
Weakness: CWE-347
Which versions are affected by CVE-2019-3465?
4 open source packages ship an affected version, including robrichards/xmlseclibs. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
robrichards/xmlseclibs Packagist | From 1.0.0 | 2.1.1 |
robrichards/xmlseclibs Packagist | From 1.0.0 | 2.1.1 |
robrichards/xmlseclibs Packagist | From 3.0.0 | 3.0.4 |
robrichards/xmlseclibs Packagist | From 3.0.0 | 3.0.4 |
Products include Debian Debian Linux, Simplesamlphp Simplesamlphp, Xmlseclibs Project Xmlseclibs.
How do I fix CVE-2019-3465?
Upgrade robrichards/xmlseclibs to a fixed version for your release line: 2.1.1 or 3.0.4.
Is CVE-2019-3465 being exploited?
There is no known exploitation of CVE-2019-3465 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-3465, DLA-1983-1, DSA-4560-1, GHSA-pqm6-cgwr-x6pf, UBUNTU-CVE-2019-3465.