CVE-2019-3498 Improper Input Validation in Django
Attackers can spoof content on 404 error pages via crafted URLs, potentially misleading users who fail to recognize malicious input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-3498?
CVE-2019-3498 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Django 1.11.x before 1.11.18, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, an Improper Neutralization of Special Elements in Output Used by a Downstream Component issue exists in django.views.defaults.page_not_found(), leading to content spoofing (in a 404 error page) if a user fails to recognize that a crafted URL has malicious content.
Weakness: CWE-74
Which versions are affected by CVE-2019-3498?
7 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.11 | 1.11.18, 2.0.10, 2.1.5 |
django PyPI | From 1.11a1 | 1.11.18 |
django PyPI | From 2.0a1 | 2.0.10 |
django PyPI | From 2.1a1 | 2.1.5 |
Django PyPI | From 1.11a1 | 1.11.18 |
Django PyPI | From 2.0a1 | 2.0.10 |
1 more packages
Django PyPI | From 2.1a1 | 2.1.5 |
Linux distribution packages (1)
python-Django SUSE:OpenStack Cloud 7 | All versions | 1.8.19-3.9.1 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2019-3498?
Upgrade django to a fixed version for your release line: 1.11.18, 2.0.10 or 2.1.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-3498 being exploited?
There is no known exploitation of CVE-2019-3498 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2019-3498, DEBIAN-CVE-2019-3498, DLA-1629-1, DSA-4363-1, GHSA-337x-4q8g-prc5, MGASA-2019-0035 and 5 more.