# CVE-2019-3774: Spring Batch XML External Entity Injection (XXE)

> Attackers can exploit XML External Entity injection in Spring Batch to read sensitive files or cause denial of service via malicious XML input.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3wc8-659g-r88q

## What is CVE-2019-3774?

CVE-2019-3774 is a critical vulnerability in Spring Batch, published on 18 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Batch versions 3.0.9, 4.0.1, 4.1.0, and older unsupported versions, were susceptible to XML External Entity Injection (XXE) when receiving XML data from untrusted sources.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-3774?

6 open source packages ship an affected version, including org.springframework.batch:spring-batch-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.batch:spring-batch-core` | Maven | All versions | 3.0.10.RELEASE |
| `org.springframework.batch:spring-batch-core` | Maven | All versions | 3.0.10.RELEASE |
| `org.springframework.batch:spring-batch-core` | Maven | From 4.0.0.RELEASE | 4.0.2.RELEASE |
| `org.springframework.batch:spring-batch-core` | Maven | From 4.0.0.RELEASE | 4.0.2.RELEASE |
| `org.springframework.batch:spring-batch-core` | Maven | From 4.1.0.RELEASE | 4.1.1.RELEASE |
| `org.springframework.batch:spring-batch-core` | Maven | From 4.1.0.RELEASE | 4.1.1.RELEASE |

Products: Broadcom Spring Batch.

## How do I fix CVE-2019-3774?

Upgrade org.springframework.batch:spring-batch-core to a fixed version for your release line: 3.0.10.RELEASE, 4.0.2.RELEASE or 4.1.1.RELEASE.

## Is CVE-2019-3774 being exploited?

There is no known exploitation of CVE-2019-3774 in the wild and no public exploit code.

## Other vulnerabilities in Spring Batch

- [CVE-2020-5411](https://insights.sbomify.com/CVE-2020-5411/): Jackson Configuration Allows Code Execution with Unknown "Serialization Gadgets" (high 8.1)
- [CVE-2026-47881](https://insights.sbomify.com/CVE-2026-47881/): Denial of Service in Spring Batch FlatFileItemReader via Malformed Input File (medium 5.9)
- [CVE-2026-47875](https://insights.sbomify.com/CVE-2026-47875/): JobParameterDeserializer bypasses the trusted-type allowlist (medium 5.6)
- [CVE-2026-47878](https://insights.sbomify.com/CVE-2026-47878/): Unsafe Java deserialization in DefaultExecutionContextSerializer without class allowlist (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3774 and fix it if it is affected.

What it is: CVE-2019-3774 is a critical vulnerability in Spring Batch, published on 18 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-3774 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.batch:spring-batch-core (Maven): affected all versions; fixed in 3.0.10.RELEASE
- org.springframework.batch:spring-batch-core (Maven): affected all versions; fixed in 3.0.10.RELEASE
- org.springframework.batch:spring-batch-core (Maven): affected from 4.0.0.RELEASE; fixed in 4.0.2.RELEASE
- org.springframework.batch:spring-batch-core (Maven): affected from 4.0.0.RELEASE; fixed in 4.0.2.RELEASE
- org.springframework.batch:spring-batch-core (Maven): affected from 4.1.0.RELEASE; fixed in 4.1.1.RELEASE
- org.springframework.batch:spring-batch-core (Maven): affected from 4.1.0.RELEASE; fixed in 4.1.1.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3774/ (Markdown: https://insights.sbomify.com/CVE-2019-3774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3774
- OSV: https://osv.dev/vulnerability/CVE-2019-3774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3774/
Summaries are generated and may contain mistakes; the official description above is the record.
