CVE-2019-3792 Concourse 5.0.0 SQL Injection vulnerability

Medium 6.8 Published Updated

An attacker can exploit a SQL injection vulnerability in the Concourse API to read privileged data from the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-3792?

CVE-2019-3792 is a medium-severity SQL injection vulnerability in Pivotal Concourse, published on 1 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Pivotal Concourse version 5.0.0, contains an API that is vulnerable to SQL injection. An Concourse resource can craft a version identifier that can carry a SQL injection payload to the Concourse server, allowing the attacker to read privileged data.

Weakness: CWE-89

Which versions are affected by CVE-2019-3792?

2 open source packages ship an affected version, including github.com/concourse/concourse. It affects 1 product.

PackageAffectedFixed in
github.com/concourse/concourse GoAll versions5.0.1
github.com/concourse/concourse GoAll versions5.0.1

Products include Pivotal Software Concourse.

How do I fix CVE-2019-3792?

Upgrade github.com/concourse/concourse to 5.0.1 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2019-3792 being exploited?

There is no known exploitation of CVE-2019-3792 in the wild and no public exploit code.

Sources

Also known as GHSA-4fqx-74rv-638w.

Is CVE-2019-3792 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free