# CVE-2019-3792: Concourse 5.0.0 SQL Injection vulnerability

> An attacker can exploit a SQL injection vulnerability in the Concourse API to read privileged data from the server.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4fqx-74rv-638w

## What is CVE-2019-3792?

CVE-2019-3792 is a medium-severity SQL injection vulnerability in Pivotal Concourse, published on 1 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pivotal Concourse version 5.0.0, contains an API that is vulnerable to SQL injection. An Concourse resource can craft a version identifier that can carry a SQL injection payload to the Concourse server, allowing the attacker to read privileged data.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-3792?

2 open source packages ship an affected version, including github.com/concourse/concourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/concourse/concourse` | Go | All versions | 5.0.1 |
| `github.com/concourse/concourse` | Go | All versions | 5.0.1 |

Products: Pivotal Software Concourse.

## How do I fix CVE-2019-3792?

Upgrade github.com/concourse/concourse to 5.0.1 or later.

## Is CVE-2019-3792 being exploited?

There is no known exploitation of CVE-2019-3792 in the wild and no public exploit code.

## Other vulnerabilities in Pivotal Concourse

- [CVE-2020-5415](https://insights.sbomify.com/CVE-2020-5415/): Concourse's GitLab auth allows impersonation (critical 10.0)
- [CVE-2020-5409](https://insights.sbomify.com/CVE-2020-5409/): Concourse Open Redirect in the /sky/login endpoint (high 7.6)
- [CVE-2018-15798](https://insights.sbomify.com/CVE-2018-15798/): Pivotal Concourse allows malicious redirect urls on login (high 7.6)
- [CVE-2018-1227](https://insights.sbomify.com/CVE-2018-1227/): Supply chain in Concourse CI: As of 2018-03-13, Pivotal does not believe that any resources or builds of Concourse have been compromised. (high 7.5)
- [CVE-2022-31683](https://insights.sbomify.com/CVE-2022-31683/): Team scope authorization bypass when Post/Put request with :team_name in body, allows HTTP parameter pollution (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3792 and fix it if it is affected.

What it is: CVE-2019-3792 is a medium-severity SQL injection vulnerability in Pivotal Concourse, published on 1 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-3792 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/concourse/concourse (Go): affected all versions; fixed in 5.0.1
- github.com/concourse/concourse (Go): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3792/ (Markdown: https://insights.sbomify.com/CVE-2019-3792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3792
- OSV: https://osv.dev/vulnerability/CVE-2019-3792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3792/
Summaries are generated and may contain mistakes; the official description above is the record.
