# CVE-2019-3795: Insecure Randomness When Using a SecureRandom Instance Constructed by Spring Security

> Spring Security allows insecure randomness if a seed is manually configured, potentially enabling attackers to predict random values.

- **Severity:** Low 3.8 (`CVSS:3.0/AV:P/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2019
- **Updated:** 17 Sep 2024
- **Also known as:** DLA-1794-1, GHSA-v2r2-7qm7-jj6v

## What is CVE-2019-3795?

CVE-2019-3795 is a low-severity vulnerability in Debian Debian Linux, published on 9 Apr 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Spring Security versions 4.2.x prior to 4.2.12, 5.0.x prior to 5.0.12, and 5.1.x prior to 5.1.5 contain an insecure randomness vulnerability when using SecureRandomFactoryBean#setSeed to configure a SecureRandom instance. In order to be impacted, an honest application must provide a seed and make the resulting random material available to an attacker for inspection.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2019-3795?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 4.2.0 | 4.2.12 |
| `org.springframework.security:spring-security-core` | Maven | From 4.2.0 | 4.2.12 |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0 | 5.0.12 |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0 | 5.0.12 |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.5 |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.5 |

Products: Debian Debian Linux, Vmware Spring Security.

## How do I fix CVE-2019-3795?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 4.2.12, 5.0.12 or 5.1.5.

## Is CVE-2019-3795 being exploited?

There is no known exploitation of CVE-2019-3795 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3795 and fix it if it is affected.

What it is: CVE-2019-3795 is a low-severity vulnerability in Debian Debian Linux, published on 9 Apr 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-3795 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 4.2.0; fixed in 4.2.12
- org.springframework.security:spring-security-core (Maven): affected from 4.2.0; fixed in 4.2.12
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0; fixed in 5.0.12
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0; fixed in 5.0.12
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.5
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3795/ (Markdown: https://insights.sbomify.com/CVE-2019-3795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3795
- OSV: https://osv.dev/vulnerability/CVE-2019-3795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3795/
Summaries are generated and may contain mistakes; the official description above is the record.
